Salling Clicker for Mac OS X 10.6 (“Snow Leopard”)

As mentioned in yesterday’s post, Salling Clicker was in need of some minor alterations to work well in Mac OS X 10.6 (“Snow Leopard”). These alterations will be rolled into a minor update labelled 3.5.2 (current public version is 3.5.1).

As I know some of you may get your hands on Snow Leopard as early as today, I want to make 3.5.2 available to you as soon as possible. Please use this link to download “beta 1” of 3.5.2:

http://www.salling.com/Downloads/SallingClicker_3.5.2v516.dmg

Please note that the application no longer needs an installer. Drag the downloaded application into /Applications and launch it. Any previously installed Salling Clicker prefPane will be uninstalled on the first launch (requiring admin authorization).

I do expect to post further betas in the coming days and/or weeks, tweaking other aspects of the update as necessary (primarily controller scripts).

Thanks for listening!

13 Responses to Salling Clicker for Mac OS X 10.6 (“Snow Leopard”)

  1. Steve Wells says:

    Excellent. Such a handy app!

  2. Thanks so much!

    ๐Ÿ™‚

  3. Daniel Zimmerman says:

    Excellent! One thing: since it’s now a self-contained application, any chance of putting in some sort of auto-update mechanism (such as Sparkle or similar)? This would make it much easier to keep up with betas, etc…

  4. Jonas says:

    @Daniel Zimmerman
    Looking into using Sparkle with Clicker, too. Already using it in Media Sync, and I’m liking it quite a bit.

  5. Ilgaz says:

    Yes, Sparkle would be great. Jonas, is it impossible to convert sparkle to windows? Is it completely tied to OS X via frameworks, language choice etc.? It is the main reason why multiplatform (windows/mac) developers doesn’t use it as far as I followed.
    Of course, if that one had time… That is another issue ๐Ÿ™‚

  6. Super, many thanks for keeping such a useful piece of software up to date!! It was the one thing that made me think about postponing my upgrade – now I can ๐Ÿ™‚ Keep up the good work! O

  7. Alexxx says:

    I test 3.5.1 and 3.5.2 at Mac OS 10.6 -worked. But when i start media remote quick time player i see “Requires QT 7.0.3 or greater. In Snow leo version 10.0

  8. Chau says:

    Thank you Jonas!

  9. Kenneth says:

    Works well, and removes the old Preference Pane as described. One minor problem is that it doesn’t seem to remove the old SEC Helper reference in one’s startup objects list… so you end up with two entries for SEC Helper in there.

    Also, would be nice to have explicit support for the K530i in the UI. ๐Ÿ™‚

    • Jonas says:

      @Kenneth: Are you sure? Whenever the (new) setup app starts, we clear out any old Login Item registrations. Did you launch the main Salling Clicker UI before checking the login items?

  10. Martin says:

    Jonas and Kenneth,

    yes, you are right, even after launching the Salling Clicker UI the login item SEC helper (old version) and new version remain in the login item list.

  11. zool says:

    Isnt it almost time to add some of the Nokia touch phones
    of the recent years to the portfolio?

    there is no support for s60v5 at all which excludes a large userbase.

    pretty lame imo