FAQFAQ   SearchSearch   UsergroupsUsergroups   RegisterRegister   ProfileProfile    Log inLog in   RSS Feed

V3 Razor silent upgrade with SC working
Goto page Previous  1, 2
 
Post new topic   Reply to topic    Salling Software Forums Forum Index -> Phone/Mac issues
View previous topic :: View next topic  
Author Message
salling
Site Admin


Joined: 27 Jul 2004
Posts: 7498
Location: Stockholm, Sweden

PostPosted: Fri Nov 17, 2006 12:29 am    Post subject: Reply with quote

CLDC-1.0. Not compatible. I think this is the pattern.

Best.
--
Jonas

[quote="blckdmnd99"][quote="salling"]As I have not seen Motorola mention V3r anywhere, I suggest we talk about "V3 models with CLDC-1.1" instead; I understand this is the determining factor that also brings in support for JSR-82 (Bluetooth from Java) in these phones.

I've put together a little user agent sniffer. Point your "questionable" phone at this WAP URL:

wap.salling.com/ua.php

Then report back the results.

Best.
--
Jonas[/quote]

Nifty.

"I get MOT-V3/0E.42.10R MIB/2.2.1 Profile/MIDP-2.0 Configuration/CLDC-1.0 UP.Link/6.3.0.0.0."

Not sure what that means but I'll stay tuned. :)[/quote]
Back to top
View user's profile Send private message Send e-mail Visit poster's website
blckdmnd99
Newbie


Joined: 04 Sep 2006
Posts: 3

PostPosted: Fri Nov 17, 2006 2:10 am    Post subject: re: CLDC Reply with quote

Ok. So I wikipediaed CLDC and did a bit of reading... So if I understand it right this is more part of the hardware or a chipset... something you can't just flash to the fancy 1.1 version. What a bummer! Thanks for the help though... No sense chasing a ghost... now I can sleep at night. ;)
Back to top
View user's profile Send private message
tiger
Newbie


Joined: 10 Dec 2006
Posts: 7

PostPosted: Sun Dec 10, 2006 1:09 am    Post subject: Reply with quote

[quote="salling"]As I have not seen Motorola mention V3r anywhere, I suggest we talk about "V3 models with CLDC-1.1" instead...[/quote]

just as a point of interest, Motorola mentions V3r on my phone's display when i go to the URL you gave.

"UA for this phone is "MOT-V3r/08.BD.85R MIB/2.2.1 Profile/MIDP-2.0 Configuration/CLDC-1.1 UP.Link/6.3.0.0.0".

tiger
Back to top
View user's profile Send private message
salling
Site Admin


Joined: 27 Jul 2004
Posts: 7498
Location: Stockholm, Sweden

PostPosted: Sun Dec 10, 2006 3:39 pm    Post subject: Reply with quote

Hi there,

For what it's worth, I've updated the WAP installer to check for compatible Motorola models; i.e., if you go to wap.salling.com and are able to install the application, it will work (unless your Moto is crippled by the carrier).

Best.
--
Jonas
Back to top
View user's profile Send private message Send e-mail Visit poster's website
tiger
Newbie


Joined: 10 Dec 2006
Posts: 7

PostPosted: Thu Dec 14, 2006 12:38 am    Post subject: Reply with quote

[quote="salling"]Hi there,

For what it's worth, I've updated the WAP installer to check for compatible Motorola models; i.e., if you go to wap.salling.com and are able to install the application, it will work (unless your Moto is crippled by the carrier).

Best.
--
Jonas[/quote]

great work, sir (yet again).

i love my unlocked, uncrippled phone. :)

tiger
Back to top
View user's profile Send private message
jabohn
Newbie


Joined: 29 Dec 2006
Posts: 1

PostPosted: Fri Dec 29, 2006 2:36 am    Post subject: Reply with quote

I recently purchased a RAZR V3c with Bell Mobility in Canada. Simply doing a file transfer with the .jar file doesn't work - there is no apparent folder to put the file (no "applications" folder) and wherever I try to stick it it won't let me.

So I tried downloading it from the phone... once I get to the download link at wap.sallingclicker.com it starts the download, then stops shortly after with this error "The connection dropped and the install did not complete. Please try installing again."

I went to your little test site and got these results:

"Motorolla V3c
up.browser/6.2.3.4.c.1.109
(GUI) MMP/2.0".

Doesn't sound like my phone will work, but I wanted to find out for sure. I think Bell has locked out some of the features perhaps???
Back to top
View user's profile Send private message
modoguru
Newbie


Joined: 18 Jan 2007
Posts: 1

PostPosted: Sat Jan 20, 2007 7:54 pm    Post subject: upgrading Razr V3 from CLDC 1.0 to CLDC 1.1 - not possible Reply with quote

I suspect the problem many of you are having is that you purchased RAZR V3's that have CLDC 1.0, and what you need are RAZRs with CLDC 1.1. Unfortunately, Motorola implemented this upgrade without changing the name of the product at all. You carrier customer service reps will also probably not have any idea what you are talking about. There is a menu in the phone that will tell you what Java CLDC version you have. I don't have the phone in front of me but in the Settings Menus there is an option for Java at the very bottom of one of the categories and it will list the CLDC version. According to the Motorola Developer web site there is no way to upgrade a CLDC 1.0 RAZR to a CLDC 1.1 RAZR. So, basically your only option if you want a V3 is to check the Java menu in Settings at the time you are buying it and verify that its CLDC 1.1, and if its not then don't buy the phone. It will all come down to how long that particular phone sat in the warehouse before it was sold. Alternatively you could always just buy the RAZR V3i or V3x, both of which sport CLDC 1.1. If your carrier does not yet sell either of these models you can prorbably pick up an unlocked version off of ebay.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Salling Software Forums Forum Index -> Phone/Mac issues All times are GMT + 2 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group