FAQFAQ   SearchSearch   UsergroupsUsergroups   RegisterRegister   ProfileProfile    Log inLog in   RSS Feed

Confusing clicker problem
Goto page 1, 2  Next
 
Post new topic   Reply to topic    Salling Software Forums Forum Index -> Scripting Salling Clicker for Windows
View previous topic :: View next topic  
Author Message
TeeJay
Newbie


Joined: 16 May 2006
Posts: 10

PostPosted: Tue May 16, 2006 2:09 pm    Post subject: Confusing clicker problem Reply with quote

Hi, A few months back I purchased Salling Clicker for Windows following a trial period. I thought it was an absolutely great app. Especially for controlling iTunes which I pipe through to an Airport Express. This means I can be in the room the music is playing and not have to return to the PC to change track etc.

Anyway, it appears to have lost some functionality. The phone still connects every time to the PC, it is able to launch powerpoint, control the mouse, shutdown the PC.

However when I click on either "Media Player" or "iTunes", it flashes briefly but doesnt enter that menu. Ive tried with the iTunes either running or closed down. I have also re-installed the latest Clicker on the PC and on the phone ... with the same result.

Any ideas ???

I can post bluetooth spec and connected items if that is of any help.

Cheers
TJ
Back to top
View user's profile Send private message
salling
Site Admin


Joined: 27 Jul 2004
Posts: 7498
Location: Stockholm, Sweden

PostPosted: Tue May 16, 2006 2:56 pm    Post subject: Reply with quote

Hi TJ,

Most likely, iTunes and WMP have lost their ability to be scripted. This tends to happen if an upgrade of these apps goes wrong (especially if anti-virus is active during the installation).

Could you please select to open the script log from Salling's system tray item menu?

We should be able to get you back on track again!

Best.
--
Jonas
Back to top
View user's profile Send private message Send e-mail Visit poster's website
TeeJay
Newbie


Joined: 16 May 2006
Posts: 10

PostPosted: Tue May 16, 2006 3:07 pm    Post subject: Reply with quote

Hi Jonas,

Thank you for your swift reply. Within the logfile I have multiple entries of this:

[quote]Tue May 16 12:10:40 2006
iTunes Remote - Microsoft JScript runtime error
[Line: 55 (1)] Automation server can't create object
[/quote]

Is there anything else you wish me to look at?

Best Regards

Tom
Back to top
View user's profile Send private message
salling
Site Admin


Joined: 27 Jul 2004
Posts: 7498
Location: Stockholm, Sweden

PostPosted: Tue May 16, 2006 4:13 pm    Post subject: Reply with quote

Hm. For some reason Salling Clicker's scripts aren't getting acccess to the file system scripting components on your system.

I can think of three reasons for this:

1. Your computer heavily managed (corporate computer with lots of lock-downs) to prevent file system access from malicious web sites.

2. The "Scripting.FileSystemObject" object is broken on your system.

3. You're using overly aggressive anti-virus software that thinks Salling Clicker is a virus.

Can you give me any hints as to which might be the problem? Also, as it used to work previously, perhaps thinking about what might have changed will give us a clue?

Best.
--
Jonas
Back to top
View user's profile Send private message Send e-mail Visit poster's website
TeeJay
Newbie


Joined: 16 May 2006
Posts: 10

PostPosted: Tue May 16, 2006 4:22 pm    Post subject: Reply with quote

Hmm lets think of what has changed since I originally installed Clicker:

Ive upgraded to MSN Messenger Live Beta
I always install Windows Update packages
Ive installed I.E. 7 Beta

I guess all of these may link into Scripting.FileSystemObject calls.

The PC is not locked down in any way, Windows XP Pro. I used to administrate a large corporate environment, and havent put any Group Policy on this PC. aaah what I did do however is add it to my Active Directory Domain (not sure on the timescale for that though).

AntiVirus - Symantec Corporate Verison 9, has been the same throughout.

I hope this info is helping!?

Cheers
TJ
Back to top
View user's profile Send private message
salling
Site Admin


Joined: 27 Jul 2004
Posts: 7498
Location: Stockholm, Sweden

PostPosted: Tue May 16, 2006 5:25 pm    Post subject: Reply with quote

Could you please check this file?

c:\windows\system32\scrrun.dll

It contains the Scripting.FileSystemObject object. Make sure this file is present, has the size of 148kb and version 5.6.0.8820.

If the file appears correct, we're likely dealing with a registry (more likely) or permissions (less likely, as you haven't made such changes) issue.

Could you also please try with the "script blocking" feature turned off in Symantec?

Best.
--
Jonas
Back to top
View user's profile Send private message Send e-mail Visit poster's website
TeeJay
Newbie


Joined: 16 May 2006
Posts: 10

PostPosted: Tue May 16, 2006 5:39 pm    Post subject: Reply with quote

Ok, file is there and of the correct size.
However the version is newer: 5.6.0.8825

Ive disabled Anti-Virus completely and just tried again ... similar result Im afraid. Plus same error message in the logfile.

Thanks for your help so far, its really appreciated.

Best regards, TJ
Back to top
View user's profile Send private message
belmatt00
Newbie


Joined: 08 May 2006
Posts: 7

PostPosted: Tue May 16, 2006 5:44 pm    Post subject: SOLVED SAME PROBLEM! Reply with quote

Ask Jonas, we've got the same issue going on, posted this in the first thread, thought this might help yah.

Heres what solved my problem, maybe it'll solve his and others?

http://support.microsoft.com/default.aspx?scid=kb;en-us;323885

download the Microsoft Windows Script 5.6 from the link, and restart.

at least thats all it took for me


matt
Back to top
View user's profile Send private message
TeeJay
Newbie


Joined: 16 May 2006
Posts: 10

PostPosted: Tue May 16, 2006 6:27 pm    Post subject: Reply with quote

Matt, I just tried this patch!

Everything sprung into life. Fantastic.

Thank you to both yourself and Jonas for helping me resolve this issue.


Additionally I can now connect with my wi-fi PDA for long distance iTunes goodness !!!

Thanks once again.

Tj
Back to top
View user's profile Send private message
belmatt00
Newbie


Joined: 08 May 2006
Posts: 7

PostPosted: Tue May 16, 2006 6:37 pm    Post subject: Reply with quote

No Need to thank me bro, I was fixing my own problem (selfishly)... you just happened to have the same one, guess my parents were right when they said I was a geek at heart huh?

Matt
Back to top
View user's profile Send private message
gdclnfn
Newbie


Joined: 31 Mar 2007
Posts: 5

PostPosted: Sun Apr 01, 2007 12:43 am    Post subject: iTunes won't launch Reply with quote

Hi,
I'm having the exact same problem as noted above. I've tried all solutions noted above to no avail. I still receive this error:

Sat Mar 31 18:37:20 2007
iTunes Remote - Microsoft JScript runtime error
[Line: 55 (1)] Automation server can't create object

I am running a fully updated version (via auto updates) of Windows XP Pro. My phone is a Mororola SLVR L7. PowerPoint Remote as well as Mouse Pointing scripts work as designed. Pretty much all other scripts will not work. Initially, I tried this software on my laptop and all of the scripts worked as designed. However, I brought it home to install on my desktop and these scripts are now failing. Great software/concept if I can get it to work. :)

Any assistance or ideas are much appreciated.

Regards,
gdclnfn
Back to top
View user's profile Send private message
salling
Site Admin


Joined: 27 Jul 2004
Posts: 7498
Location: Stockholm, Sweden

PostPosted: Sun Apr 01, 2007 2:38 am    Post subject: Re: iTunes won't launch Reply with quote

This is THE most common problem and fix:

http://www.salling.com/forums/viewtopic.php?t=3373

Best.
--
Jonas

[quote="gdclnfn"]Hi,
I'm having the exact same problem as noted above. I've tried all solutions noted above to no avail. I still receive this error:

Sat Mar 31 18:37:20 2007
iTunes Remote - Microsoft JScript runtime error
[Line: 55 (1)] Automation server can't create object

I am running a fully updated version (via auto updates) of Windows XP Pro. My phone is a Mororola SLVR L7. PowerPoint Remote as well as Mouse Pointing scripts work as designed. Pretty much all other scripts will not work. Initially, I tried this software on my laptop and all of the scripts worked as designed. However, I brought it home to install on my desktop and these scripts are now failing. Great software/concept if I can get it to work. :)

Any assistance or ideas are much appreciated.

Regards,
gdclnfn[/quote]
Back to top
View user's profile Send private message Send e-mail Visit poster's website
gdclnfn
Newbie


Joined: 31 Mar 2007
Posts: 5

PostPosted: Sun Apr 01, 2007 5:50 am    Post subject: iTunes still won't launch Reply with quote

Jonas -

Wow! Amazing response time. Thank you. Unfortunately, this did not solve my problem. I completely removed AVG Anti-Virus Free and then uninstalled/reinstalled iTunes. I closed pretty much all (optional) processes running in the background on my PC so I don't think anything else would have affected the iTunes installation.
I don't know if this is worth noting but the WinAmp script (http://www.salling.com/Downloads/AWinamp.zip) does work properly.

Thanks in advance,
gdclnfn
Back to top
View user's profile Send private message
salling
Site Admin


Joined: 27 Jul 2004
Posts: 7498
Location: Stockholm, Sweden

PostPosted: Sun Apr 01, 2007 6:05 pm    Post subject: Reply with quote

I'm afraid somethings wrong with your system (not iTunes, as I originally thought). This line fails in the script:

var fso = new ActiveXObject( "Scripting.FileSystemObject" );

It could fail for a number of reasons. "Over-zealous" anti-virus software is one of them.

But, it looks like someone else had the exact same problem a while back, and there's a solution:

http://www.salling.com/forums/viewtopic.php?t=3840

EDIT: sorry about linking to the same place as TeeJay above, but I believe it's the cure for your problem. Either way, the problem is with your system; not with Clicker itself.

Best.
--
Jonas
Back to top
View user's profile Send private message Send e-mail Visit poster's website
gdclnfn
Newbie


Joined: 31 Mar 2007
Posts: 5

PostPosted: Mon Apr 02, 2007 4:08 am    Post subject: Reply with quote

I don't know if this helps diagnose my problem of iTunes not launching, but iTunes does launch when I use another similar (but INFERIOR) product (Blueshareware's Bluetooth Remote Control). The display of that other product is awful therefore I really would like to get your version working. Do you still believe it is a system problem of mine even though the other software does allow iTunes to launch?

Regards,
gdclnfn
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Salling Software Forums Forum Index -> Scripting Salling Clicker for Windows All times are GMT + 2 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group