FAQFAQ   SearchSearch   UsergroupsUsergroups   RegisterRegister   ProfileProfile    Log inLog in   RSS Feed

SOLVED: Automation server can't create object

 
Post new topic   Reply to topic    Salling Software Forums Forum Index -> Scripting Salling Clicker for Windows
View previous topic :: View next topic  
Author Message
Mark
Newbie


Joined: 18 Oct 2008
Posts: 3

PostPosted: Sat Oct 18, 2008 5:33 pm    Post subject: SOLVED: Automation server can't create object Reply with quote

Hi guys,

Wondering if anyone might be able to point me in the right direction to solve this... I have a script which I'm attempting to use to send xPL messages (home automation) from salling clicker.

When I double click to run the script directly, everything works fine. When I attach it to a menu in Salling Clicker, the following message appears in the script log:

Sat Oct 18 16:24:12 2008
Turn on the lounge lights - Microsoft JScript runtime error
[Line: 1 (1)] Automation server can't create object

Here is the script:

var xPL = new ActiveXObject("xPL.xPLCtl");
xPL.Initialise("MARKT-SALLING.MEDIAPC", false, 5);
var xplMsg = "address=lounge-light1\nunit=0\ncommand=on\n";
xPL.SendXplMsg("xpl-cmnd","*","homeeasy.basic",xplMsg);

Any help would be much appreciated!

Thanks,

Mark.


Last edited by Mark on Sun Oct 19, 2008 10:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
Mark
Newbie


Joined: 18 Oct 2008
Posts: 3

PostPosted: Sun Oct 19, 2008 3:38 pm    Post subject: Reply with quote

Ok, now I'm getting:


Sun Oct 19 13:55:07 2008
Turn on the lounge lights - xPL
[Line: 6 (1)] Component 'MSWINSCK.OCX' or one of its dependencies not correctly registered: a file is missing or invalid

I've tried regsvr32 this ocx. I've also reinstalled the VB6 runtimes.

I *ONLY* get this when attempting to trigger the script through Salling. If I double click it in explorer, ir runs with no issues.

Has anyone any ideas? I nearly defected to Windows Sideshow yesterday... I don't think it's as powerful though as long as I can get salling working!

Cheers,

Mark.
Back to top
View user's profile Send private message
Mark
Newbie


Joined: 18 Oct 2008
Posts: 3

PostPosted: Sun Oct 19, 2008 10:56 pm    Post subject: Reply with quote

Ok guys,

I did a few things to fix this so I'm not sure if they together have done the trick but the last step I took was to install the version of mswinsck.ocx from here:
http://www.afreeocx.com/ocx/download/3326/mswinsck.ocx

by copying it to C:\windows\system32 and running "regsvr32 mswinsck.ocx" from an Administrative Command Prompt.

I'd previously had a different version of the mswinsck.ocx file installed and that didn't work.

I also have installed the vb6 runtimes. A DLL pack from here: http://www.ascentive.com/support/3126InstallList.html and tried copying and registering some ocx files from a different Vista machine!

Anyway - all working now so if anyone has a similar problem then might be worth trying some of these steps.

Weird how the script worked outside of Salling though....
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Salling Software Forums Forum Index -> Scripting Salling Clicker for Windows All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group