FAQFAQ   SearchSearch   UsergroupsUsergroups   RegisterRegister   ProfileProfile    Log inLog in   RSS Feed

O2 XDA EXEC / QTEK 9000 problem.

 
Post new topic   Reply to topic    Salling Software Forums Forum Index -> Windows/Bluetooth blues?
View previous topic :: View next topic  
Author Message
ChrisLeeworthy
Newbie


Joined: 17 Sep 2006
Posts: 7

PostPosted: Mon Sep 18, 2006 3:07 pm    Post subject: O2 XDA EXEC / QTEK 9000 problem. Reply with quote

Before anything else Jonas I want to say thanks for this app, it's excellent!

Now down to the problem.

My phone is an O2 XDA EXEC, which is the O2 branded QTEK 9000.

I downloaded and installed salling clicker, connected up without any problems and used it without problems too.

Then I finished and closed down the computer.

The next time I started up the PC and tried to use clicker I had a problem.

The "connect using bluetooth" option on the menu was greyed out so I tried using "reconnect" instead. This found clicker and went into the negotiation stage where it froze.

This happens all the time and the only solution I have at the moment is to reset the phone before I use clicker again.

It's a minor gripe but if you've seen how long it takes a QTEK 9000 to boot up you'll know what a pain it is!

One other minor thing, I can't seem to find an option to actually quit the iTunes application on the iTunes remote control am I missing it somewhere?

Thanks

Chris.
Back to top
View user's profile Send private message
salling
Site Admin


Joined: 27 Jul 2004
Posts: 7498
Location: Stockholm, Sweden

PostPosted: Mon Sep 18, 2006 7:57 pm    Post subject: Reply with quote

Hi Chris,

Things will change in the next version, but here are my thoughts with respect to what you're reporting now:

1. Try enabling Bluetooth (I think it may be turned off when you reset the QTEK).

2. There is no option to Quit iTunes, so you're not missing anything.

Best.
--
Jonas
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ChrisLeeworthy
Newbie


Joined: 17 Sep 2006
Posts: 7

PostPosted: Mon Sep 18, 2006 11:41 pm    Post subject: Reply with quote

Sorry Jonas I think I need to explain this a bit more clearly. Lets see how this try goes...

I use salling clicker successfully with phone and pc.

I close the pc down.

The phone with bluetooth is left switched on at all times.

I switch the pc on again (the pc always boots up with bluetooth switched on so that end of the link should be ok).

When I call up salling clicker on the phone this time the option to connect via bluetooth is greyed out even though bluetooth is active.

I try the reconnect option which gets to the negotiation stage and then freezes.

I reset the phone (not a hard reset so all settings and software on the phone remain intact).

When I fire up clicker on the phone after the reset the option to connect via bluetooth works and all is fine.

I shut down the pc when finished and the next time I use it I go through the same cycle again.

I don't switch off the bluetooth at any point, and clicker works fine once I reset the phone so I don't think lack of bluetooth is the problem.

I hope you don't think I'm being overly pedantic, its just that, as a software developer myself I know its much easier to investigate an issue if you have full and clear details :)

Thanks for your time and please keep up the excellent work!

[quote="salling"]Hi Chris,

Things will change in the next version, but here are my thoughts with respect to what you're reporting now:

1. Try enabling Bluetooth (I think it may be turned off when you reset the QTEK).

[/quote]
Back to top
View user's profile Send private message
salling
Site Admin


Joined: 27 Jul 2004
Posts: 7498
Location: Stockholm, Sweden

PostPosted: Tue Sep 19, 2006 10:33 am    Post subject: Reply with quote

Hi Chris,

I do not think you're being pedantic. What you're describing sounds like a real problem.

However, I fail to understand how restarting the PC would affect whether the "Connect via Bluetooth" menu command is enabled or not (we do not constantly sniff for the computer; the phone doesn't know that your restarted your PC).

What if you do not restart your PC? Can you connect -> disconnect -> connect -> etc...?

Best.
--
Jonas
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ChrisLeeworthy
Newbie


Joined: 17 Sep 2006
Posts: 7

PostPosted: Sun Sep 24, 2006 11:04 pm    Post subject: Reply with quote

OK, I'm a few days older but feeling no wiser :?

Once everything is running I can repeatedly connect and disconnect without a problem.

However, if I leave the phone for a while, it seems to forget that bluetooth is available on the phone. The 'connect using bluetooth' option is greyed out, and selecting the 'start listening' option does nothing.

When I try using the 'reconnect' option, the phone does find the PC and goes into the negotiation phase, this locks up with the message 'Waiting for response'. I was paying special attention this time and noticed a message on the PC which came up briefly.

The message said something like 'unable to establish an outgoing connection (bluetooth stack didn't say why)'.

I've even tried a hard reset and reinstalling clicker, I'd got some rubbish on the phone that needed getting rid of anyway, but the problem persists.

As I reported before if I do a soft reset on the phone then everything works again.
Back to top
View user's profile Send private message
salling
Site Admin


Joined: 27 Jul 2004
Posts: 7498
Location: Stockholm, Sweden

PostPosted: Thu Sep 28, 2006 12:16 am    Post subject: Reply with quote

Chris,

Please email me privately. I'd like to have you try something.

Best.
--
Jonas
Back to top
View user's profile Send private message Send e-mail Visit poster's website
adhir
Newbie


Joined: 10 Dec 2006
Posts: 1

PostPosted: Sun Dec 10, 2006 9:08 pm    Post subject: Reply with quote

[quote="salling"]Chris,

Please email me privately. I'd like to have you try something.

Best.
--
Jonas[/quote]

I am experiencing the exact same problem with my Sprint PPC-6700, Windows Mobile 5. Was this issue ever resolved, and if so, how can I resolve on my device?

Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Salling Software Forums Forum Index -> Windows/Bluetooth blues? All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group