FAQFAQ   SearchSearch   UsergroupsUsergroups   RegisterRegister   ProfileProfile    Log inLog in   RSS Feed

SlimServer Remote for Windows (Beta)
Goto page Previous  1, 2, 3, 4, 5  Next
 
Post new topic   Reply to topic    Salling Software Forums Forum Index -> Scripting Salling Clicker for Windows
View previous topic :: View next topic  
Author Message
simbo
Senior Member


Joined: 28 Jul 2006
Posts: 78
Location: UK

PostPosted: Fri Aug 10, 2007 11:36 am    Post subject: Reply with quote

OK it appears to be failing at the point where it's getting the length of the track from SlimServer, which fits with your symptoms.

I've attached a modified version of the script file that [i]should[/i] write more information to the logs about what's being returned by SlimServer.

A few other questions:-
- What version of SlimServer are you running?
- Does it fail on any track you play?
- Some SlimServer skins, such as Fishbone, show you the song progression in the web UI. Do these work for you?
- What format are the files you're playing?



SlimServer Remote.zip
 Description:
SlimServer Remote 0.1.1 (Debug) Script file only. Not for general use.

Download
 Filename:  SlimServer Remote.zip
 Filesize:  9.26 KB
 Downloaded:  870 Time(s)

Back to top
View user's profile Send private message
jrog
Newbie


Joined: 09 Aug 2007
Posts: 9

PostPosted: Fri Aug 10, 2007 6:40 pm    Post subject: Reply with quote

In the version you attached, a lot more seems to be working than the previous version.
- The track number/total number of tracks are displayed
- The cover is available :-)
- The title, artist, and album is displayed

Still missing:
- Track length/Total track length


Are you sure nothing but the debugging level is changed?

[quote="simbo"]
A few other questions:-
- What version of SlimServer are you running?
- Does it fail on any track you play?
- Some SlimServer skins, such as Fishbone, show you the song progression in the web UI. Do these work for you?
- What format are the files you're playing?[/quote]

- SlimServer Version: 6.5.3 - 12376 - Windows XP - EN - cp1252
- Do you mean if the media stream fails, if that is what you mean the answer is no. I am pretty sure none of the files are corrupted
- When I change to the Fishbone skin, the song progression is shown.
- All the files are mp3 files

Attached is the new log file, thanks again for your help

/Jrog



ScriptErrorLog.txt
 Description:

Download
 Filename:  ScriptErrorLog.txt
 Filesize:  8.08 KB
 Downloaded:  960 Time(s)

Back to top
View user's profile Send private message
simbo
Senior Member


Joined: 28 Jul 2006
Posts: 78
Location: UK

PostPosted: Fri Aug 10, 2007 8:42 pm    Post subject: Reply with quote

[quote="jrog"]Are you sure nothing but the debugging level is changed?[/quote]
OK I confess... by catching the media-length error and logging it, I'm allowing the script to continue past the failure point so the remaining functionality will work.

To be honest I'm not sure why it doesn't work so I'm resorting to trying things out. I've attached an updated script file below. It won't log anything this time but please let me know if the track position is working. If not... well this file will at least give you the rest of the funcionality while I investigate further.



SlimServer Remote.zip
 Description:
Clicker Remote 0.1.1b (Debug). Script file only. Not for general use.

Download
 Filename:  SlimServer Remote.zip
 Filesize:  9.23 KB
 Downloaded:  918 Time(s)

Back to top
View user's profile Send private message
jrog
Newbie


Joined: 09 Aug 2007
Posts: 9

PostPosted: Sat Aug 11, 2007 8:50 am    Post subject: Reply with quote

Great! the total time/remaining and progress bar are all there :-D

There seems to be introduced something new though in both the previous debugging version and this latest version (I didn't mention this in the previous post to avoid discussing to many issues at once). Here it goes:

I've experience the issue occurring in the following situations:
- starting clicker and choosing SlimServer Remote
- changing to the next track
- the phone has reached the end of one track and starts with the next in the playlist.
(I guess they are all related to the same code though(code retrieving the player status information))

my pc displays an error message:
"The script you are executing is taking longer than expected to run. Click End to abort the script, or Continue to continue script execution".

When either of the situations above occurs, the error message is displayed after approx 10 seconds on my pc, and the phone display is updated after approx 15 seconds (without me responding to the dialog, it disappears when the response is received after the 15 secs).

NOTE: When changing the track, the player changes the track "immediately", but the phone UI is not updated for the approx 15 seconds

/Jrog
Back to top
View user's profile Send private message
simbo
Senior Member


Joined: 28 Jul 2006
Posts: 78
Location: UK

PostPosted: Sat Aug 11, 2007 9:33 am    Post subject: Reply with quote

Is there anything in the logs that might give a clue? Also, does this happen when Clicker is running on the same PC as SlimServer?

A 5 second delay is quite normal, maybe a little more at the beginning of a new track (when album art etc has to be sent to your mobile) but anything more is unusual and the error is very strange. My guess is that SlimServer is taking a while to return data but I don't see why it would only do that at the end of tracks.

Is your CPU being ramped up by SlimServer? If so, you might want to change the Poll Interval (under Settings), moving the gauge to the right.
Back to top
View user's profile Send private message
jrog
Newbie


Joined: 09 Aug 2007
Posts: 9

PostPosted: Sat Aug 11, 2007 10:26 am    Post subject: Reply with quote

There does not seem to be produced any log at the moment. Didn't you turn off logging?

Yes, I'm running Clicker and SlimServer on the same PC.

Yes the CPU is boosted until the response is received, but the process utilizing the processing power is WinClicker.exe

I've tried installing Clicker on my desktop computer and the delay seems to be even greater on this one.

It also looks like the current track time on my phone is incorrect due to this issue. Maybe the current time is "extracted" on the server some time before the response is received by the phone. (I guess the current time on the phone is produced by adding the number of seconds since the response was received to the track time received in the response). In this case this should prove that the delay is introduced somewhere after the point where the current track time is extracted.
Back to top
View user's profile Send private message
jrog
Newbie


Joined: 09 Aug 2007
Posts: 9

PostPosted: Sat Aug 11, 2007 5:08 pm    Post subject: Reply with quote

I've investigated a little further, and it seems like this issue might be connected to the mp3 files that I am playing. Some files work flawlessly others does not. If I have a playlist containing for example three tracks and one of the files has this symptom. The WinClicker.exe process will use all remaining CPU when:
- The player has finished the previous track and changes to this one
- I skip forward to this track
- I skip backwards to this track

I have several files that all has this problem. I could send some of them to you to see if you are able to recreate the problem? I am not comfortable with uploading them in the forum though :) And I see private messages are disabled in this forum. Do you have any other way I can send them to you?

/Jrog
Back to top
View user's profile Send private message
rbryant
Newbie


Joined: 28 Aug 2007
Posts: 8

PostPosted: Wed Aug 29, 2007 8:21 pm    Post subject: C Reply with quote

Can I go back a few steps please guys?

I have got as far as getting Salling Clicker onto my phone, a Nokia N95, but it just controls itunes, Powerpoint and MediaPlayer in basic form as I am sure you know. I read your posts, but do not know what to do with your scripts, whether I should be doing something on the PC or phone or both, in what order and how ..... in short, any chance of an idiot guide to getting me up and running?

Very much appreciated, thanks
Back to top
View user's profile Send private message
melquiades
Junior Member


Joined: 24 Nov 2006
Posts: 50
Location: Washington, DC

PostPosted: Thu Aug 30, 2007 2:44 am    Post subject: Reply with quote

rbryant,

It sounds like you need help installing 3rd party scripts in general. I can help with this, but if you're looking for help on how to use the actual script, someone else will have to chime in since I don't have slimserver.

To install 3rd party scripts:

1. Download, then unzip the .js and .xml files into your "My Clicker Scripts" folder, located in your "My Documents" folder (you can create subfolders here if you want).
2. Double click on the Clicker icon in your system tray and select the "Clicker Items" tab.
3. Under "Scripts" (right side), locate the script you want to install, and drag/drop it over to the left side.
4. Click "Apply", "Close", and the script will be loaded onto your phone.

Note: This is generally the process with 3rd party scripts. Each script usually comes with its own "readme" file which is worth looking at before before installing.

Mel
Back to top
View user's profile Send private message
rbryant
Newbie


Joined: 28 Aug 2007
Posts: 8

PostPosted: Sat Sep 01, 2007 7:14 pm    Post subject: Reply with quote

Fantastic, thanks Mel, and Simbe - great bit of software - got there in the end
Back to top
View user's profile Send private message
rjl
Newbie


Joined: 22 Sep 2007
Posts: 4

PostPosted: Sat Sep 22, 2007 6:27 pm    Post subject: Using Palm TX for Slimserver Remote Reply with quote

I downloaded the script for the slimserver for windows for use on my Palm tx and everything seems to work except I get no album art in the now playing track display. I downloaded the file album art checking and I only see one display of the cover. Can I get some help on getting the artwork. Otherwise, everything else works great. Thanks.
Back to top
View user's profile Send private message
simbo
Senior Member


Joined: 28 Jul 2006
Posts: 78
Location: UK

PostPosted: Sat Sep 22, 2007 6:43 pm    Post subject: Re: Using Palm TX for Slimserver Remote Reply with quote

[quote="rjl"]I downloaded the script for the slimserver for windows for use on my Palm tx and everything seems to work except I get no album art in the now playing track display. I downloaded the file album art checking and I only see one display of the cover. Can I get some help on getting the artwork. Otherwise, everything else works great. Thanks.[/quote]
Please can you try the "Clicker Remote 0.1.1b (Debug)" script that's attached to an earlier post and let me know if that works any better for you?
Back to top
View user's profile Send private message
rjl
Newbie


Joined: 22 Sep 2007
Posts: 4

PostPosted: Sat Sep 22, 2007 6:52 pm    Post subject: Reply with quote

Simbo

Thank you. I just tried the "Clicker Remote 0.1.1b (Debug)". I replaced it in the folder in My Documents / My Clicker Scripts. Again everything works but on the media screen I get the track playing with the progress bar on a background with no artwork.
Back to top
View user's profile Send private message
rjl
Newbie


Joined: 22 Sep 2007
Posts: 4

PostPosted: Wed Oct 10, 2007 1:05 am    Post subject: Reply with quote

I see some posts that version 3.5 no longer supports slimserver. Thats really a shame and may be the reason the artwork function is not working. Does anyone recommend trying an earlier version to get this script to show the artwork?
Back to top
View user's profile Send private message
salling
Site Admin


Joined: 27 Jul 2004
Posts: 7498
Location: Stockholm, Sweden

PostPosted: Wed Oct 10, 2007 7:20 am    Post subject: Reply with quote

The Windows version of Clicker never supported Slimserver out-of-the-box.

Best.
--
Jonas

[quote="rjl"]I see some posts that version 3.5 no longer supports slimserver. Thats really a shame and may be the reason the artwork function is not working. Does anyone recommend trying an earlier version to get this script to show the artwork?[/quote]
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Salling Software Forums Forum Index -> Scripting Salling Clicker for Windows All times are GMT + 2 Hours
Goto page Previous  1, 2, 3, 4, 5  Next
Page 4 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group