FAQFAQ   SearchSearch   UsergroupsUsergroups   RegisterRegister   ProfileProfile    Log inLog in   RSS Feed

Bluetooth is unavailable

 
Post new topic   Reply to topic    Salling Software Forums Forum Index -> Windows/Bluetooth blues?
View previous topic :: View next topic  
Author Message
jhepotz
Newbie


Joined: 18 Mar 2008
Posts: 7

PostPosted: Tue Mar 18, 2008 11:44 am    Post subject: Bluetooth is unavailable Reply with quote

Salling clicker is now installed on my laptop (Sony) with Bluetooth Stack for Windows by Toshiba Version v5.10.04(SO), my Nokia 6680 and my Nokia N80.

I tried setting up my Nokia N80 first but it says "Bluetooth in unavailable" right after the "Installing Salling Clicker on your phone" part. The "Select phone.." bar cannot be selected and is dimmed.

I tried to do it on my Nokia 6680 but the same thing happened.

What could be wrong?

The Support Information part says:

Toshiba Bluetooth: No device present.
Execution mode: Elevated.
Bonjour: Enabled.

Thanks!
Back to top
View user's profile Send private message Yahoo Messenger
Jester
Newbie


Joined: 18 Mar 2008
Posts: 3

PostPosted: Tue Mar 18, 2008 12:28 pm    Post subject: Reply with quote

Looks like your BT stack can't find a device on your laptop. Has nothing to do with your phones.

Can you see any Unknown devices in device manager in Windows?
Back to top
View user's profile Send private message
salling
Site Admin


Joined: 27 Jul 2004
Posts: 7498
Location: Stockholm, Sweden

PostPosted: Tue Mar 18, 2008 12:47 pm    Post subject: Reply with quote

What version of Windows are you on there?

Also, I guess I should ask whether Bluetooth is turned on or off on your computer.

Best.
--
Jonas
Back to top
View user's profile Send private message Send e-mail Visit poster's website
jhepotz
Newbie


Joined: 18 Mar 2008
Posts: 7

PostPosted: Tue Mar 18, 2008 1:58 pm    Post subject: Reply with quote

[quote="salling"]What version of Windows are you on there?

Also, I guess I should ask whether Bluetooth is turned on or off on your computer.

Best.
--
Jonas[/quote]

I'm using Windows XP Service pack 2.
And yes, my Bluetooth is turned on.
Back to top
View user's profile Send private message Yahoo Messenger
jhepotz
Newbie


Joined: 18 Mar 2008
Posts: 7

PostPosted: Tue Mar 18, 2008 2:00 pm    Post subject: Reply with quote

[quote="Jester"]Looks like your BT stack can't find a device on your laptop. Has nothing to do with your phones.

Can you see any Unknown devices in device manager in Windows?[/quote]

No Unknown devices in my device manager. What could be really wrong? :?
Back to top
View user's profile Send private message Yahoo Messenger
salling
Site Admin


Joined: 27 Jul 2004
Posts: 7498
Location: Stockholm, Sweden

PostPosted: Tue Mar 18, 2008 3:02 pm    Post subject: Reply with quote

Quit Clicker on your PC.

Then run the attached registry modification to enable heavy logging.

Then launch Clicker again.

You can email me the resulting log file using the email button (above or below this post). The log file is here:

%APPDATA%\Salling Software AB\Salling Clicker\Log.txt

Best.
--
Jonas
Back to top
View user's profile Send private message Send e-mail Visit poster's website
jhepotz
Newbie


Joined: 18 Mar 2008
Posts: 7

PostPosted: Tue Mar 18, 2008 4:30 pm    Post subject: Reply with quote

[quote="salling"]Quit Clicker on your PC.

Then run the attached registry modification to enable heavy logging.

Then launch Clicker again.

You can email me the resulting log file using the email button (above or below this post). The log file is here:

%APPDATA%\Salling Software AB\Salling Clicker\Log.txt

Best.
--
Jonas[/quote]

This is what the Log file said:

ERROR [Tue Mar 18 16:38:36 2008]
GetAdaptersAddresses() = 111



Did i do it right?
Quit the program then Run this '%APPDATA%\Salling Software AB\Salling Clicker\Log.txt' right?

Thanks for your quick responses :)
Back to top
View user's profile Send private message Yahoo Messenger
jhepotz
Newbie


Joined: 18 Mar 2008
Posts: 7

PostPosted: Tue Mar 18, 2008 4:42 pm    Post subject: Reply with quote

And also, whenever I try to connect using my phone, it always says:
'Salling Clicker does not appear to be launched on this computer.'

Thing is, the Clicker is launched.
Back to top
View user's profile Send private message Yahoo Messenger
salling
Site Admin


Joined: 27 Jul 2004
Posts: 7498
Location: Stockholm, Sweden

PostPosted: Tue Mar 18, 2008 5:19 pm    Post subject: Reply with quote

Sorry. I forgot to attach the reg file...


Enable Logging.reg
 Description:

Download
 Filename:  Enable Logging.reg
 Filesize:  290 Bytes
 Downloaded:  1298 Time(s)

Back to top
View user's profile Send private message Send e-mail Visit poster's website
jhepotz
Newbie


Joined: 18 Mar 2008
Posts: 7

PostPosted: Wed Mar 19, 2008 3:55 am    Post subject: Reply with quote

[quote="salling"]Sorry. I forgot to attach the reg file...[/quote]

Okay here's what I got.
Thanks again!



Log.txt
 Description:

Download
 Filename:  Log.txt
 Filesize:  11.87 KB
 Downloaded:  1606 Time(s)

Back to top
View user's profile Send private message Yahoo Messenger
jhepotz
Newbie


Joined: 18 Mar 2008
Posts: 7

PostPosted: Mon Mar 31, 2008 11:45 am    Post subject: Reply with quote

A little help here, please?
Back to top
View user's profile Send private message Yahoo Messenger
salling
Site Admin


Joined: 27 Jul 2004
Posts: 7498
Location: Stockholm, Sweden

PostPosted: Mon Mar 31, 2008 12:49 pm    Post subject: Reply with quote

Thank you for the extended log file. It was very helpful. The Toshiba Bluetooth stack gives us this:

[quote]TOSBTAPI_ERROR_DEVICE_NOT_READY FFFFFFFE
(-2) Device is not working.
(Device driver is not loaded or device driver
could not be loaded because the power of BT
module is not ON, etc.)[/quote]

So we assume that the device is turned off, as per the error definition.

Is your Bluetooth hardware working properly?

Best.
--
Jonas
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Octo
Newbie


Joined: 14 Mar 2006
Posts: 3
Location: Ottawa, ON, Canada

PostPosted: Wed May 07, 2008 2:39 am    Post subject: Reply with quote

I just purchased a Kensington Bluetooth USB micro adapter and it is using the Toshiba driver and I am having the same problem. I didn't run the debug, but I can if needed.

After the first reboot I had Clicker connect, but I was unable to transfer files via bluetooth so I unpaired the device and then I have been unable to reconnect. I know the blue tooth is working because the Nokia software is connected without issue via bluetooth.
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger
salling
Site Admin


Joined: 27 Jul 2004
Posts: 7498
Location: Stockholm, Sweden

PostPosted: Wed May 07, 2008 11:07 am    Post subject: Reply with quote

Please run the debug log thing, Octo, and I'll try to help you out.

Best.
--
Jonas

[quote="Octo"]I just purchased a Kensington Bluetooth USB micro adapter and it is using the Toshiba driver and I am having the same problem. I didn't run the debug, but I can if needed.

After the first reboot I had Clicker connect, but I was unable to transfer files via bluetooth so I unpaired the device and then I have been unable to reconnect. I know the blue tooth is working because the Nokia software is connected without issue via bluetooth.[/quote]
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Octo
Newbie


Joined: 14 Mar 2006
Posts: 3
Location: Ottawa, ON, Canada

PostPosted: Wed May 07, 2008 1:35 pm    Post subject: Reply with quote

I ran the debug and had a look at it. I didn't like the way that the drivers were being reported so I checked to see how the radio was being identified in Device Manager. It was being reported as a Generic Bluetooth Radio, so I switched to a different driver and everything appears to be working.

Thanks
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    Salling Software Forums Forum Index -> Windows/Bluetooth blues? All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group